Water pump?

crazyhorsecrazyhorse Member Posts: 19
I put muffs on low water pressure but no water going through the boat and my alarm sounded, I shut the boat off after about 1 minute , could I have over heated it and does this sound like an engine water  pump  issue or a lower unit pump issue  and will both be fried now??

Comments

  • aero3113aero3113 Long Island, NYMember Posts: 7,359 ✭✭✭✭✭
    How low of water pressure did you use? I usually give it a decent amount of pressure, the muffs aren’t sealed tight and will release excess pressure when the engine isn’t running.
    2008 330EC
  • crazyhorsecrazyhorse Member Posts: 19
    I gave if full pressure the second time 
  • GMSLITHOGMSLITHO Greenwood Lake NY Member Posts: 1,243 ✭✭✭
    edited October 2019
    Bravo 3 drive when I run it on the muffs I put a piece of duct tape on the cone to cover the hole in front otherwise the water won’t pick up or run it in a big plastic tub 
  • Liberty44140Liberty44140 Bay Village & Marblehead, OH.Member Posts: 3,859 ✭✭✭✭✭
    I don’t have the front hole but I use my hands to hold the muffs tight over the drive intakes until I get decent flow and then can let go
    07' Cruisers 390 (Previous Rinker's: 06' 342EC & 01' 310FV)

  • crazyhorsecrazyhorse Member Posts: 19
    It says low pressure in the manual...wont do that again..but also my motor was emptied about a week ago was just about to winterize 
  • rasburyrasbury Sanford, FLMember Posts: 6,953 ✭✭✭✭✭
    I have bad luck with the muffs..I have q secondary thru hull and it just does not work well on the muffs m
  • Liberty44140Liberty44140 Bay Village & Marblehead, OH.Member Posts: 3,859 ✭✭✭✭✭
    Ras me too, I make sure to close the thru hull valve when running on muffs, otherwise it just comes right out the thru Hull 
    07' Cruisers 390 (Previous Rinker's: 06' 342EC & 01' 310FV)

  • cowboybraxcowboybrax Member Posts: 5
    I have the same problem when i was winterizing. Alarm was going crazy. i stop it right away. how was your engine. I did replace my water pump, I found out that water pump starts burning and has some missing empeller blade. now im worry for the spring. what if I cannot find the missinf rubber impeller it could clug my cooling line. hopefully its gonna be there by the thermostst when i open. i will keep you all posted.

  • rasburyrasbury Sanford, FLMember Posts: 6,953 ✭✭✭✭✭
    most likely will blow it right out but do check...it only takes a few seconds...if there is another thru hull that can leak the slightest bit your in trouble...
Sign In or Register to comment.