Options

Stereo speakers

aero3113aero3113 Member Posts: 8,930 ✭✭✭✭✭
I installed my batteries before and wanted to listen to some music. I turned on the radio and I was getting good sound out of 2 of the arch speakers and the 2 cabin speakers. All of the 4 other speakers on deck I could just barely hear some bass. I didn’t play around too much with it, is this an adjustment in the head unit or amp? Below is a pic of the amp that’s installed.


2008 330EC

Comments

  • Options
    aero3113aero3113 Member Posts: 8,930 ✭✭✭✭✭
    edited March 2020
    There’s a chance I might have plugged the RCA jacks in wrong when I installed the Bluetooth receiver. Possibly?
    2008 330EC
  • Options
    YYZRCYYZRC Member Posts: 4,995 ✭✭✭✭✭
    Did you check your cones? Mine are original except the arch speakers and the cones are all cracked and crumbling. Bought all new speakers.
    2008 350 EC on Georgian Bay
  • Options
    aero3113aero3113 Member Posts: 8,930 ✭✭✭✭✭
    I replaced the 2 lower arch speakers only because the grills were cracked. It’s the 2 upper arch speakers that are working correctly. The rest of the speakers are very low volume bass. I don’t remember if the speakers did this when I first bought it.
    2008 330EC
  • Options
    aero3113aero3113 Member Posts: 8,930 ✭✭✭✭✭
    I found this picture online, there’s a chance I plugged the RCA jacks in different. I might have put both white on top and both red on the bottom. I’ll have to check and see if that’s what I did.


    2008 330EC
  • Options
    LaReaLaRea Member, Moderator Posts: 7,627 mod
    Could you have accidentally changed the x-over switch from "OFF" to "LPF"?  Only the amp that feeds the subwoofer should be on LPF (low-pass filter).  
  • Options
    aero3113aero3113 Member Posts: 8,930 ✭✭✭✭✭
    @LaRea , would my boat have come with a subwoofer installed? Or are the speakers acting like a sub? I haven’t seen one installed. I will check the switches also.
    2008 330EC
  • Options
    Liberty44140Liberty44140 Member Posts: 4,354 ✭✭✭✭✭
    When I bought my boat some speakers didn’t work, it was because the rca from the amp to head unit were loose, so yes check that. Also I’ve got to my boat in the spring and had some speakers not work and when I adjusted my amp gains up and down the speakers came to life. Just sat so long that something froze up. I’ve also heard that there is something in the amp that almost has to click to work and after sitting all winter that gets stuck so just leave the music on a couple
    of hours and it may come to life and be fine all summer
    07' Cruisers 390 (Previous Rinker's: 06' 342EC & 01' 310FV)

  • Options
    aero3113aero3113 Member Posts: 8,930 ✭✭✭✭✭
    edited March 2020
    @LaRea , drinks on me! The lower cross over was on LPF, switched it to off. All good! I had the music blasting, my wife sends me a text “what’s that music”. She’s inside with the windows shut about 40 yards away. LoL


    2008 330EC
  • Options
    LaReaLaRea Member, Moderator Posts: 7,627 mod
    Your terms are accepted!
Sign In or Register to comment.