Options

Temp gauge issue

Starboard temp gauge isn't reading.  located the temp sending unit on the 2003 Mercruiser 5.0, at least I hope I did(brass on the thermostat housing with the tan wire) Tried grounding to see if the gauge pegged, no luck, reseated the gauge wires still no luck.  I was thinking that my only option is replace the gauge...or do I go with a NMEA and merc monitor?....any thoughts on those smart gauges?

Thanks, 
Brian

Also let me say, as a new owner we're loving our boat and it's great to have a community back.

Comments

  • Options
    Dream_InnDream_Inn Member, Moderator Posts: 7,589 mod
    I connected up with vessel view and since then only rely on it!  I had installed Northstar to smartcraft on my last boat as well.  Absolutely single handedly the best thing I ever did on the boat.  Any alarms, it tells you in plane english exactly what the alarm is.  I just helped someone last Friday connect theirs up, but still having some issues with it.

    Dream 'Inn III -- 2008 400 Express

  • Options
    raybo3raybo3 Administrator Posts: 5,468 admin
    Hey Brian why not try swapping the gauge with the port gauge and see what happens? At least you will be able to tell if its the gauge, sending unit or wiring. Good luck and keep us posted..
    2002 342 Fiesta Vee PC Point Of Pines YC Revere MA. popyc.org     raybo3@live.com
  • Options
    brianflhrcibrianflhrci Member Posts: 62 ✭✭
    GREAT IDEA!  I feel like an idiot for not thinking of that.  Thanks!
  • Options
    brianflhrcibrianflhrci Member Posts: 62 ✭✭
    Swapped the gauges and it looks like the gauges are fine, I'll replace the sending unit this week.  Thanks for the help.
  • Options
    raybo3raybo3 Administrator Posts: 5,468 admin
    Awesome hope all works out for you......
    2002 342 Fiesta Vee PC Point Of Pines YC Revere MA. popyc.org     raybo3@live.com
  • Options
    brianflhrcibrianflhrci Member Posts: 62 ✭✭
    Replaced the sending unit, no luck!  Finally replaced the thermostat and gasket with the grommets and cleaned all of the contacts and BINGO!  temp gauge works.  Thanks for all of the feedback.
Sign In or Register to comment.